こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

PHPでParse errorについて

PHPでParse errorについて

PHP設置した際に
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /当HPのアドレス/VoteBorn/VoteController.php on line 9

が表示されているのですが
9行目付近を見直しても間違えがわかりません。

<?php
//VoteControllerから見たMatrixController.phpへの相対パス
require_once "./MatrixController.php";

//Version 1.00
//Made by Nearliquid

class VoteController extends MatrixController {
private $col_list = array("id", "name", "Vote");
private $target_row = NULL;//ターゲットの行
private $target_vote = NULL;//ターゲットの投票数
private $now_row;

public function makeFile($vote_file) {
$this->makeMatrix($vote_file, $this->col_list);
}

//この関数を使わないと、これより下の関数は使用できない。
public function readFile($fp) {
$this->readMatrix($fp);
}

public function checkNameCrash($name) {
if($this->getTargetRow("name", $name) === FALSE) {//登録予定の名前は現在投票システム上には存在しない
return(TRUE);
} else {//二重登録
return(FALSE);
}
}

以下略・・・・

申し訳ないのですが
是非ご教示の程よろしくお願いします

投稿日時 - 2013-05-16 23:02:20

QNo.8091315

すぐに回答ほしいです

質問者が選んだベストアンサー

<?php

echo PHP_VERSION;

?>

これでPHPのバージョンが見れます。
もし古いものを使われている場合は、新しいバージョンに乗り換えてください。

最低: 5.3
推奨: 5.4 or 5.5

レンタルサーバーの場合は、別のサーバーを検討してください。

投稿日時 - 2013-05-16 23:45:41

お礼

ありがとうございました
ver5.5でのレンタルサーバーに乗り換えました

投稿日時 - 2013-05-22 21:45:35

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(5)

ANo.5

>最低: 5.3
>推奨: 5.4 or 5.5
残念ながらPHP 5.3のサポートを終了しています。(2013/3末で5.3のサポート終了)
最低が5.4です。

投稿日時 - 2013-05-17 08:08:57

ANo.4

To_aru_Userさんが正解。

PHP 4.4で 現象の再現を確認しました。

ただの報告です。

投稿日時 - 2013-05-17 03:06:40

ANo.2

privateが予約語に入ってないってことは・・・
まさかPHP4を使われているってことはありませんよね・・・????

(今時PHP4なんてあり得ない・・・)

投稿日時 - 2013-05-16 23:41:47

ANo.1

そういうエラーは出ませんね。
貼り付けた物が間違っているのでは?

投稿日時 - 2013-05-16 23:34:38

-広告-
-広告-

あなたにオススメの質問

-広告-
-広告-