こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Compact 3.5とVS2012

SQL Server Compact 3.5 SP2について教えてください。
現在、SQL Server 2008R2で運用されているWebアプリケーションシステムがあります。
ASP.NETで作られており、データアクセスはLINQ for SQLで動作しています。

今回、ちょっとしたサーバ移転があり、データアクセスの頻度がさほど高くない理由から、SQL Server Compact 3.5での稼働を計画しています。
(Compact 4.0だとLINQが動作しないらしいので)

で、開発環境(VS2012)にてSQL CE3.5のファイルを作ろうとしたところ、サーバエクスプローラのプロバイダ選択画面で、CE3.5も4も出てきません。
(通常のSQL Serverや、mdf形式のSQL Serverプロバイダは正しく出てきます)

そこで質問なのですが、

・SQL Server CE3.5はVisual Studio 2012に対応しているのでしょうか?
・皆さんのVisual Studio 2012では、SQL Server CEをデータプロバイダとして、サーバエクスプローラを動作させることができますか?

よろしくお願いします。

投稿日時 - 2012-10-02 20:09:15

QNo.7728824

すぐに回答ほしいです

質問者が選んだベストアンサー

えーと、たぶんSQL Server Compact Edition 3.5は、ASP.NETに対応していなかったと思います。
対応したのはFramewok 4のASP.NETからかな?
3.5CEはLINQのデータソースとして選択できるけど使えないと思います。

あと、SQLServer CE(3.5、4とも)は、Visual Studioと別製品。WebMatrixなんかだったらインスコされるけど、Visual Studioだけだと入らないよ。

インストーラがあるので、そちらからダウンロードしてインストールしてみてください。

投稿日時 - 2012-10-05 21:13:05

お礼

shockatz様、いつも拙い質問に親切にお答えいただき、本当に感謝いたします。

そうだったのですか! SQL ServerCE 3.5はASP.NET未対応だったのですね。。知らなかった。。
ドキュメント見たらたしかに記述ありました。
でも4.0だと、思い切りEntity Frameworkなんですね。すいません。勉強不足で。。

LINQ for Entityが使えそうなので、移植を頑張ってみます。
今回も、本当にありがとうございました。

投稿日時 - 2012-10-09 01:20:27

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(1)

-広告-
-広告-
-広告-
-広告-