こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

SQLServer2005 SP3 インストール失敗

Windows XP SP3 のパソコンに
Visual Studio 2005 Professional Editionをインストールしました。
そのときVisual StudioについてきたSQL Server Developer Editionも同時に
インストールしました。

こないだMicrosoftUpdateを行ったのですが、
Microsoft SQL Server 2005 Express Edition Service Pack 3(KB955706)
のアップデートでエラー(エラー番号2BC9)になりアップデートに失敗します。

ネットで調べ
Microsoft SQL Server 2005 Service Pack 3
(Express EditionではないSP3)をインストールするとよいと
書いてあったので実行したところ、インストールは完了したのですが、

そのあとまたMicrosoftUpdateを実行すると、更新プログラムにはいまだ
Microsoft SQL Server 2005 Express Edition Service Pack 3(KB955706)
が表示され、実行するとエラーになります。

いまは、↓の2つの疑問があります。

1.Developer EditionでもSP3はExpress Editionのバージョンをインストールするのか?
(SP3をインストールするにはどのバージョンをインストールすればよい?)

2.SQL Server 2005 Developer Editionでのバージョン確認方法

どちらかでもよいのでわかるかたおしえてください

投稿日時 - 2009-04-16 21:25:35

QNo.4884872

困ってます

質問者が選んだベストアンサー

#1,#2です。

結局インストールされているのはExpressでしたか?
(サービス名はSQL Server(SQLEXPRESS)なっていましたか?)

ローカルのSQL Serverは全く使っていないと書かれていたので少し気になったのですが、SSMSで接続するときにローカルのSQL Server Expressに接続しましたか?(localhost\SQLEXPRESSに接続しないで、どこかリモートのSQL Serverに接続したなんてことはないですよね)。
インスタンスの横に表示されるバージョンはそのインスタンスのバージョンです。だから、リモートのSQL Serverに接続したのだったら、そのリモートのSQL Serverのバージョンになります。

そこは間違いないということならば、結局インストールがうまくいっていないということになるのでしょうね。SQL Server Express自体をアンインストール&インストールするのも一つの手ですね。

投稿日時 - 2009-04-18 04:20:49

お礼

>結局インストールされているのはExpressでしたか?
サービス名を確認したときにSQLEXPRESSとは書いてありませんでした。
ということは、EXPRESSではないのでしょうか。

>(localhost\SQLEXPRESSに接続しないで、どこかリモートのSQL Serverに接続したなんてことはないですよね)。
もしかしたら、インストール時に確認のためローカルではなくリモートのSQLServerに接続してるかもしれません。そのパソコンでは、全くSQLServerの機能は使っていないかなと思い、接続先の確認を忘れてました。。。
明日確認してみます。

>SQL Server Express自体をアンインストール&インストールするのも一つの手ですね。
そうですね。今回のお話を聞いてアンインストールしたほうが良い気がしてきました。

インスタンスのバージョン表示が接続先のだということをすっかり忘れていました。。。
自分1人で考えていたら絶対思い出さなかったと思います。
何回も回答頂きまして本当にありがとうございました。

投稿日時 - 2009-04-19 22:38:59

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(3)

ANo.2

>MicrosoftUpdateではExpress用のSP3をインストールしようとしているのが不思議なのですが、、、
Visual Studioかなにかをインストールしていませんか?
デフォルトではExpressが一緒に入るはずです。Expressがあるかどうかは、サービスの有無を確認すればわかります。

>もしよろしければjamshid6さんが対処した方法を教えて頂けないでしょうか?
私のは「SQL BPA Commandは動作を停止しました」でした。
やはりネットで調べて、gacutilでBPAClient.dllをレジストしなおしたらうまくいきました。まあ、Expressだけで4インスタンスも入れていたからその影響もあるのかもしれませんが。。

投稿日時 - 2009-04-17 00:23:16

補足

再び回答頂きましてありがとうございます。

>Visual Studioかなにかをインストールしていませんか?
はい。Visual Studio2005をインストールしています。
Visual Studio2005の説明を見ていたら一緒にSQL Server Developer Edition
をインストールすると書いてあったのでてっきりDeveloper Edition
だと思っていたのですが、、、
今日出勤したらさっそくサービスを確認します。

>gacutilでBPAClient.dllをレジストしなおしたらうまくいきました。
教えて頂きありがとうございます。
この方法はネットで見つけることができませんでした。

>まあ、Expressだけで4インスタンスも入れていたからその影響もあるのかもしれませんが。。
インスタンス数も影響するかもしれないんですね。
私の環境ではインストールのみで実際には使用していないのですが、
こちらの方法も試してみようかと思います。
ありがとうございました。

投稿日時 - 2009-04-17 07:35:28

お礼

今日、教えて頂いた方法
1.MSXML6 SP2をアンインストールしてからインストール
2.gacutilでBPAClient.dllをレジストしなおす
試し、インストールはできたのですが、
教えて頂いた方法でバージョン確認をするとSP2のままでした。
うまくいったと思ったのですが、、、
jamshid6さんには2回も回答頂きありがとうございました。
引き続き調べてみようと思います。

投稿日時 - 2009-04-17 23:47:36

ANo.1

まず、Expressとそれ以外(Developer含む)は別物と考えてください。
質問者さんの場合、DeveloperにはSP3があたっていると思いますが、Expressは別にExpress用のをあてないといけません。
バージョンについては、ログイン後にSSMSでインスタンスの横に表示される番号が、
9.00.3042以降ならSP2、9.00.4035以降ならSP3です。

インストールの失敗はいくつかパターンがあるようですが、エラー番号だけだとわかりません。
エラー内容がメッセージボックスに出るか、ログの場所が示されているかどちらかのはずですので、
具体的に何がエラーかを確認することをお勧めします。

ちなみに「MSXML6 SP2をアンインストールしてからインストールすると成功する」というのが多いようですが、
ちなみに私は別のメッセージで別の対処をしました。

投稿日時 - 2009-04-16 21:44:54

補足

ありがとうございます。
やっぱりExpressとそれ以外は別物なのですね。
なぜDeveloperをインストールしているのに
MicrosoftUpdateではExpress用のSP3をインストールしようとしているのが
不思議なのですが、、、

バージョンの確認方法を教えていただきありがとうございます。
明日会社に出勤したときエラー内容も含めて確認しようと思います。

MSXML6 SP2アンインストールも教えていただきありがとうございます。
アンインストールでエラーになってしまいそのままにしていました。
Windows Install Clean Upでアンインストールできることがわかったので
こちらも明日試してみます。

もしよろしければjamshid6さんが対処した方法を教えて頂けないでしょうか?

投稿日時 - 2009-04-17 00:02:19

-広告-
-広告-

あなたにオススメの質問

-広告-
-広告-