こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

DHCPサーバーからIPアドレスを取得出来ません

前にも書込んだハズなのですが、なぜか消えてしまったので再度質問します。

マザーボード:AOpen AX63 Rro
CPU:Pentium2 450MHz
メモリ:320MB
OS:Windows95 4.00.950 C の環境で、

PLANEX ENW-8300-T(PCI接続)又はcorega Ether2 ISA-T(ISA接続)のLANアダプタからiTSCOM(CATV)のインターネットサービスに接続しようとしているのですが、以下のエラーで接続出来ません。

エラーメッセージ
「このDHCPクライアントはDHCPサーバーからIPネットワークアドレスを取得できませんでした。」

確認した内容
1.ケーブルモデム~10BASE-Tは別のクライアントに接続すれば問題なく動作することから、障害はないと思われます。
2.LANアダプタは(どちらを接続した場合も)デバイスマネージャから認識出来ており、IPを割り当ててPINGを投げると問題なく帰ってきます。
3.コントロールパネルのネットワーク構成は、いずれかのLANアダプタのドライバとTCP/IPのみがインストールされた状態で、削除~再インストールで確認しました。
4.TCP/IPの設定はiTSCOMに確認し、IPアドレスを自動取得、WINSの解決にDHCPを使う、DNSを使わないに設定し、ゲートウェイ、NetBIOS、詳細、バインドは何も設定されていない状態です。
5.WINIPCFGから全て更新をかけました。
6.ケーブルモデムの電源を切~入でハード的にリセット、念のためiTSCOM側からソフト的にリセットする信号を投げてもらいました。

加えて、OSをクリーン再インストールした状態で、上記作業を繰り返しましたが、全く状況は変わりません。
アドバイスをいただければ嬉しいです。

よろしくお願いいたします。

投稿日時 - 2002-05-10 19:24:00

QNo.267848

すぐに回答ほしいです

質問者が選んだベストアンサー

> クライアントからルーターにUDPを投げてますよとのアラートが1回出ます。
1回だけですか。
ということは、PCからDHCPサーバーに要求はでているが、それが帰ってきてないということになりますね。
BBルーターでIPが取得できることから、PCからパケットそのものが出ていっていないということはないでしょうし。

> ミリ秒などと言うレベルでなく、分単位は必要な位です。(笑)
分単位でもミリ秒で設定したりします(^^)
10分なら10(min)×60×1000=600000といった感じで。
やっても意味ないですけど。

> ルーターに対してはLAN側もWAN側も1msで返って来ますが、
予想と違いましたね(^^;
ルーターには問題ないようですね。

> WAN内のプロバイダのルーターやDNSに投げると、20~50ms位かかります。
これはルーターなしの時ですか。
タイムアウトするような時間には見えないのですが。
もし、ルーターありのときなら、下の「結果」はもう一度考え直す必要があるかもしれません。

> これを手動で、
>「DHCPサーバーのところが拾えていない」と言う状態になります。
DHCPサーバーを使用していないのですから、こうなるでしょう。
pingが通る(DHCP使用時と挙動が同じ)ようであれば、問題ないです。

Tiny personal firewallに関しては他のサイトでもトラブルを起こしているのを見つけました。
Win95(日本語版のみ?)に対しては動作確認が甘いのかも知れません。



当初、Win95のDHCPクライアント機能がうまく動かなかったというのが気になりますが、一応私が考える結果です。

ケーブルモデム(もしくはiTSCOMの機器の一部)がLANケーブルから来たパケットを変換して、CATV回線に送りこむ際に機能不全を起こしているように思えます。
そのため、Mac以外で接続した時にトラブルが出てきたのではないかと。
まずLAN内での結果ですが、Win95はBBルーターからIPを取得できたことからTCP,UDPともに正常に機能しており、DHCPクライアントの機能にも異常は無いと判断します。また、LAN内でのpingの結果はMacの時と同じであり、Win-Mac間のpingの送受信にも問題ないことから、Win95のTCP/IPの機能は正常であると考えられます。
次に、BBルーターを用いたときには、ケーブルモデムは機能不全を起こしながらも一応機能しており、このためルーター自身もDHCPでIPを取得でき、Win・Macからのpingも異常なほどの速度低下を起こしながらも返ってきたのだと思います。Win・MacでHPを見に行こうとしたときにタイムアウトになったのも、このせいでしょう。
最後にモデムにWin95機を直結した場合ですが、この時にはモデムはほぼ完全に機能しておらず、Win95機から出たDHCPの要求パケットをサーバーに届けることができなくなっているのではないかと思います。

以上、推論を重ねている部分もあり、なぜMacだけ正常だったのかなど、突っ込む所はいろいろ有ると思いますが、こんな所でいかがでしょうか?
BBルーター付きのプロバイダへのpingの応答時間を測定してからになるとは思いますが、iTSCOMのサポートのほうへ、各機器(モデム以外も)の動作や接続を調査してもらうように頼んではいかがでしょうか?

投稿日時 - 2002-05-17 16:51:26

お礼

いろいろお世話になりましたが、ついに開通しました!

原因はhofuhofuさんの予想通り、モデムの不具合(相性)でした!

ここでのいろんな方のアドバイスや検証結果をもとにiTSCOMと交渉し、
Macで接続出来てるなら・・・とモデム交換をしぶる営業を
サポート担当にも協力してもらって説き伏せ、モデム交換したら・・・

ここまで皆さんを騒がせたのはなんだったの?って位、
な~んの問題もなく開通しちゃいました。
ルーターをかまそうが、どうしようが問題なし!

本当にいろいろありがとうございました。
また、訳わかんないことを聞くかもしれませんが、今後ともよろしくお願いいたします。

投稿日時 - 2002-05-22 12:45:12

ANo.12

このQ&Aは役に立ちましたか?

5人が「このQ&Aが役に立った」と投票しています

回答(12)

ANo.11

今回はちょっと質問項目が多いので、「補足要求」です。

> また、Tiny Personal Firewallを使った時のダイアログ4回はご指摘の通り出て来ます。
これは、ルーター無しのときですか?
有りのときでしたら、DHCPでIPが取得できるようになったということですから、問題ないです。
もし、無しのときで正しく送受信が4回あり、それでもエラーメッセージが出てくるようであれば、サーバーから送られてくるパケットに問題がない限り、Win95にも問題があることになります。

> (ただし、死ぬ程スピードが遅いので、URLを検索しに行ったままタイムアウトします。)
レジストリのHKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet SettingsにDWORD値でReceiveTimeoutという項目を作成し、ミリ秒でタイムアウトの時間を指定することで、タイムアウトの時間は延ばすことができます。
設定することで、一応どっかのHPを見れるようになるかもしれません。
あと、Macからでもタイムアウトになりますか?
どんなにスループットが悪くても、ルーターをつけただけでタイムアウトになるほど遅くなるはずがないのですが。
ELECOMのサポートのほうにも、連絡しなければならないかもしれまれせん。
NAT等を使用していれば、ルーターはIPを2つ(LAN側とWAN側)持っているはずですが、WAN側のIPへpingを打ったときのレスポンスはどうなりますか?
あと、DHCPでDNSなどIP以外の情報の取得は正しくできていますか?
ルーターとPC、両方とも確認してみてください。

> ルーター経由でプロバイダに打った時は「Request timed out.」ですから、
このエラーはpingのタイムアウトの時間を延ばしてやることで、回避できるはずです。
オプションは-wで、単位はミリ秒で指定します。
使い方は、
ping -w [ミリ秒] [IP]
です。
やってもあんまり意味ないですけど(^^;

> ルーターを経由しない時のメッセージは「Destination host unreachable.」ですので
これは、ルーターなどに問題がなければ、TCP/IPの設定がおかしいときに出てきます。
DHCPでIPが取得できないのですから、出てくるでしょう。

> Tiny Personal Firewallを入れた状態でPINGを打つと、当然ダイアログが出ますが、
> その時にシステムエラーが出てしまったので(100%再現・エラーメッセージは見えない)
> いったんFirewallをアンインストールしました。
とりあえず、設定画面の'Firewall Enabled'のチェックを外してやれば、アンインストールしなくても、たぶん大丈夫だと思うのですが。
再インストールして、OSは比較的クリーンな状態にあるはずなのに、おかしいですね。

> この状況はTCP/IPで「IPを自動取得」にした時だけで、手入力するとダメです。
普通はいけると思うのですが。
ダメというのは、どのような状態か、教えてもらえますか?
あと、一応手入力の設定(IP,GATEWAY,NETMASK)も教えてもらえますか?

投稿日時 - 2002-05-16 01:57:48

補足

連日連夜、本当にお手数をおかけします。

>これは、ルーター無しのときですか?
「アリ」の時です。「なし」の時は(一部文字化けで読めませんが)
クライアントからルーターにUDPを投げてますよとのアラートが1回出ます。

>ミリ秒でタイムアウトの時間を指定することで、タイムアウトの時間は延ばすことができます。
ミリ秒などと言うレベルでなく、分単位は必要な位です。(笑)
Macクライアントでも同様にタイムアウトで開けません。

>WAN側のIPへpingを打ったときのレスポンスはどうなりますか?
ルーターに対してはLAN側もWAN側も1msで返って来ますが、
WAN内のプロバイダのルーターやDNSに投げると、20~50ms位かかります。

>再インストールして、OSは比較的クリーンな状態にあるはずなのに、おかしいですね。
クリーンもクリーン。IE5.5を入れただけの状態ですが、
Firewallを入れておくと、何度かPINGやWINIPCFGをチェックしてるうちに
システムエラーを誘発しますので、とりあえず外したままにしてあります。

>ダメというのは、どのような状態か、教えてもらえますか?
まず、自動設定にした時の状況ですが、WINIPCFGの画面で
ホスト名:catv.ne.jp
DNSサーバー:iTSCOMのものを拾っています
ノードタイプ:ブロードキャスト
IPアドレス:192.168.1.10
サブネット:255.255.255.0
ゲートウェイ:192.168.1.1
DHCPサーバー:iTSCOMのものを拾っています

これを手動で、
IP:192.168.1.10
サブネット:255.255.255.0
ゲートウェイ:192.168.1.1
DNS:iTSCOMのものを入れてます。(ホスト名:catv.ne.jp)
WINS:(本来DHCPを使うにするのですが)ここでは選べないので「解決しない」
と設定すると、

「DHCPサーバーのところが拾えていない」と言う状態になります。

・・・こんなところで答えになってますでしょうか?

それにしても、ルーターを入れるとDHCPからIPが取れると言うことは
ルーターの機能が効いているからで、なければ取れないと言うことは
やはりOS内のTCP/IPの設定かファイルそのものがおかしいと言うことになるんでしょうね?

しかし、そうなるとiTSCOMユーザーの多くが接続出来なくなるだろうから、
LANアダプタとiTSCOMの相性かLANアダプタとOSの相性ってことになるんでしょうか?

さらにしかし、2枚あるLANアダプタでいずれも症状が出ると言うことは、
マザーボードあたりが怪しくなってくるのでしょうか・・・?(泣)

投稿日時 - 2002-05-17 14:02:52

ANo.10

LAN内のpingの挙動はいたって正常に見えますね。
それだけに、WAN側へのpingの挙動が不可解ですが。
ルーターに対してのpingはLAN側とWAN側、両方確認されましたか?
多分、返ってくるとは思うのですが、念のため。
あと、一応Macからも同様の手順でpingで(ルーター無しの状態でも)確認して頂けますか。
ツールには'Mac TCP Ping'というソフトが使えると思います。
参照URLに書いておきます。
あと、pingの失敗したときのエラーメッセージを教えてもらえますか。


ただ、DHCP以前にWANに向けてのpingの挙動がおかしいというのが、問題ではないかと思います。
win95のping自体は問題ないように見えるので、ルーターかiTSCOM側の設備の方に問題があるような気がします。
ルーターの不具合であれば、メーカーのHPにファームウェア等の情報があると思います。coregaのwireless LANなどはiTSCOMに接続しようとした場合に不具合が生じるようですし。あと、まだ聞いていなかったのでルーターの型番を教えてもらえますか。
それと、モデム等のチェックや交換をサポートの方に頼めませんか?


ちょっと確認したいのですが、文面からルーター=ブロードバンドルーターと勝手に判断していたのですが、よろしいですか?
それで、ルーターのDHCPサーバーの機能を使っても、IPの取得に失敗されているのですよね。
もしそうであれば、ルーターに対してpingは通るのにDHCPでIPは取得できないわけですから、Win95のほうにも問題があるということになります。

一応、前回紹介したTiny Personal Firewallの使い方を簡単に。
1. タスクトレイから設定画面を起動
2. セキュリティレベルを'Ask Me First'に
3. WINIPCFGで'解放'を押す。
4. '書き換え'を押して、Outgoing(送信)とIncoming(受信)のダイアログが交互に、計4回出てくるのを確認する
出てくるダイアログは全てpermitにしてください。押すタイミングが遅すぎると、タイムアウトになり、同じダイアログが2回でてくることがあります。

参考URL:http://www.jismug.com/software/macping.html

投稿日時 - 2002-05-15 03:12:53

補足

またしても問題がややこしくなりそうな気配です。(笑)

まずはMacからPINGを打った時の状況ですが・・・
1)自分自身にPING --> 100%成功
2)ルーターにPING --> 100%成功
3)95クライアントにPING --> 100%成功
4)ルーター経由でプロバイダにPING  --> 100%成功(相当遅くなる)
5)ルーターを経由せずプロバイダにPING  --> 100%成功
で、ここまでは予想通りです。
ルーターはご想像通りブロードバンドルーターで、ELECOM LD-BBR4です。

次にWindowsクライアントからPINGを打った時のエラーメッセージですが、
ルーター経由でプロバイダに打った時は「Request timed out.」ですから、
ルーターを経由することでスピードが遅くなってのエラーかと思いますが、
ルーターを経由しない時のメッセージは「Destination host unreachable.」ですので
本当に届いてないものと判断しています。

また、Tiny Personal Firewallを使った時のダイアログ4回はご指摘の通り出て来ます。

・・・以下は、今日起こった状況です。
Tiny Personal Firewallを入れた状態でPINGを打つと、当然ダイアログが出ますが、
その時にシステムエラーが出てしまったので(100%再現・エラーメッセージは見えない)
いったんFirewallをアンインストールしました。
(神に誓って、昨日と変わっているのはFirewallを入れて、消しただけです。)

そして再起動すると・・・なんと「ルーター経由なら」IPが取得出来るようになりました。
つまり、プロバイダ側になんらかの仕様変更があったとしか考えられません。
(ただし、死ぬ程スピードが遅いので、URLを検索しに行ったままタイムアウトします。)

この状況はTCP/IPで「IPを自動取得」にした時だけで、手入力するとダメです。
また、ルーターを経由しない状態では昨日までと変わりません。

・・・と言う訳で、少し絞り込めたような、深みにはまったような状況です。

投稿日時 - 2002-05-15 21:10:50

ANo.9

> やはりIPの取得は出来ませんでした。
手動でTCP/IPの設定を行えば、DHCPでIPを取得する必要がないですから、DHCPのほうに問題があってもインターネットに接続できるのではないかとおもったのでが。
LAN内ではDHCPと手動のどちらを使っても、iTSCOMのほうには影響ないですし。

ちょっと調べてみたのですが、DHCPでIPを取得する際、4回パケットの送受信が行われるそうです。
手順としては簡略化して書くと、
(1)サーバにIPを申請
(2)使用可能なIPがサーバから送られてくる
(3)どのIPを使うかサーバに申請
(4)使用許可が送られてきて、IPが使用可能になる
といった感じです。
パケットの出入りを監視できるようなファイアーウォール用のソフトをお持ちであれば、それでどの段階で止まっているのかチェックされてはいかがでしょうか。
具体的な解決策にはつながらないかも知れませんが、原因の解明には役立つかと。
私はTiny personal firewall(旧バージョンが個人使用に限りフリー)を使ってますが、これでも4回パケットが出入りしているのを確認できました。


>(その設定のままでPINGも100%通る訳ではなく、4回に1~2回は失敗します。)
普通はIPが設定されていなければ、全部返って来なくなるはずですが。
よくわかりませんね。
これで、TCP/IPそのものに問題があるような気もしてきました。
ところで、質問文の2にあるLANアダプタにpingを打ったというのは、自分自身に向けてだけでしょうか。
たとえLANケーブルを外していても、自分自身へのpingは返ってきますから、win機から外部にパケットがきちんと出て行っているかどうかは、わからないと思います。
ルーターに複数のポートが用意されていればの話ですが、WinとMacをそれぞれルーターに接続し、手動でIPを設定したのち、Mac側にpingを打ってみてはどうでしょうか。
ルーターのWAN側は接続しなくても結構です。いきなり、WAN側にpingを打ってもややこしくなるだけですし。

投稿日時 - 2002-05-14 03:01:51

補足

早速アドバイス通りTiny personal firewall(ver2)を入れてみました。
いまいち使い方がよくわからないので、これについてはもう少しいじくってみて、
改めて結果をご報告いたします。

PINGに関しては
1)自分自身にPING --> 100%成功します
2)ルーターに対してPING --> 100%成功します
3)ルーター経由でMacintoshに対してPING --> 100%成功します(ちょっと遅い?)
4)ルーター経由でプロバイダに対してPING --> 4回に1~2回失敗します。
5)ルーターを経由せずプロバイダに対してPING --> 100%失敗します。

こんな状況です。

投稿日時 - 2002-05-14 22:52:55

ANo.8

ルーターを使ったときの設定が、よくわかないのですが。

ルーターのLAN側のIPを192.168.1.1に固定し、そこからWin95へDHCPでIPを割り振るようにしたが、Win95ではIPを取得できなかった、ということでよろしいのでしょうか?

もし、そうであればLAN側のDHCPを停止し(しなくてもいけるでしょうけど)、Win95に手動でTCP/IPの設定されてはいかがでしょう。
設定の内容は
IP          192.168.1.xxx(2~254)
SUBNET MASK  255.255.255.0
GATEWAY     192.168.1.1
DNS        ルーターがWAN側で受け取ったものと同じ
ぐらいです。
根本的な解決にはならないですけど。


> MacのTCP/IPの場合、これを書込む欄があるのです。
Macでの接続のほうに、確かにありました。
失礼いたしました。


> 3のURLは何も見えないのでよくわかりません。
あれ、見えませんでしたか?
DEC ALPHAマシン上のSP2を入れたWinNT4.0ServerがDHCPでIPのリースに失敗するというものですが、まず関係ないでしょうね。
このままでは、気持ち悪いでしょうからもう一度。
http://support.microsoft.com/default.aspx?scid=%2Fisapi%2Fgomscom%2Easp%3Ftarget%3D%2Fjapan%2Fsupport%2Fkb%2Farticles%2Fjp409%2F3%2F90%2Easp&LN=JA

投稿日時 - 2002-05-12 17:20:09

補足

>ルーターを使ったときの設定が、よくわかないのですが。
おっしゃる通りです。
で、アドバイスいただいた方法を私も思いついたので、試してみたのですが、
やはりIPの取得は出来ませんでした。
(その設定のままでPINGも100%通る訳ではなく、4回に1~2回は失敗します。)

ルーターをかませたやり方に関しては問題の切り訳がややこしくなるので、
現在は除外していますが、全く症状が改善せず、
メーカーのサポートもプロバイダのサポートもお手上げ状態にはまり込んでいます。

Microsoftのサイトに関しては、たまにあるんです。
Windowsでは問題ないけど、Macでは真っ白になって見ることが出来ないサイト・・・。

投稿日時 - 2002-05-13 22:06:46

ANo.7

> 95クライアントにファイルを移動させる方法がなくて挫折しました。
Mac用のファイル分割のソフトを使われてはどうでしょう。
Vectorで調べてみたら、'MacSplit'と'bsplit'というのが使えそうです。
URLをのせておきます。
Windows(DOS)フォーマットしておけば、MacでもWindowsでもFDは読めます。

> 95クライアントから同じIPにPINGを投げてもダメでした。
サポートの方に連絡を取り、許可をもらってから、一時的に手動でTCP/IPの設定をすることはできませんか?
もし、これでも接続できないようであれば、DHCP以前の話になってきます。
サーバ側でこういった設定がはじかれる可能性もありますが・・・。

> DHCPも参照する設定をするだけで、その手がかりとして「catv.ne.jp」の
どういうことなんでしょう。
iTSCOMのHPにはそれらしい記述はありませんでしたが?


関係ないとは思うのですが、原因になりそうなものを3つほど。
1. ファイアーウォール関連のソフトなどは入っており、UDPの67,68番(DHCP)あたりを塞いでいる。
2. 一部のプロバイダではコンピュータ名(ホスト名)に指定されたものを入力する必要がある。
3. http://www.microsoft.com/japan/support/kb/articles/J029/4/24.htm

参考URL:http://www.vector.co.jp/soft/mac/util/se061554.html,http://www.vector.co.jp/soft/mac/util/se052303.html

投稿日時 - 2002-05-12 14:02:47

補足

何から何までありがとうございます。

実は私も「分割すれば何とかなるかも」と思い、ISHで分割してましたが、
95側でDLLが要るだのVBのランタイムが要るだのでうまくいかず、凹んでました。(笑)

教えていただいたソフトで「分割~復元」が成功しましたので、試してみます。

手動IP設定の件は、私も思いついて頼んでみたのですが、その方法では接続出来ないとの回答でした。
代替案としてルーターをかませることで、こちらのIPを固定(192.168.1.1)する方法を試したところ、

1.WINIPCFGでは「IPは取得出来ない」状態
2.プロバイダのルーターに対してPINGを投げると4回に1~2回は通る状態
(ルーターなしの直結で上記IPにPINGを投げても100%失敗します。)
と、ますます訳がわからなくなりました。(サポートも困り果ててます。)

さて、DHCP参照の「catv.ne.jp」ですが、
契約した時に配付された資料に書いてあるもので、MacのTCP/IPの場合、
これを書込む欄があるのです。
Windowsの場合はこれに当たるような設定はないらしいのですが・・・。

原因になりそうな3点のうち1、2はありません。
3のURLは何も見えないのでよくわかりません。

投稿日時 - 2002-05-12 15:01:29

ANo.6

外しているかもしれませんが、下記参考URLのページの下の方に在る「必要なTCP/IPドライバのアップデート」のWin95の項にあるアップデート、つまり、DUN 1.3 や Winsock2 の導入が必要かどうか、iTSCOMにご確認ください。

参考URL:http://member.nifty.ne.jp/oso/optrwin/

投稿日時 - 2002-05-11 23:25:40

補足

お世話になります。

iTSCOMのサポート担当に確認したところ、やってみてうまくいく可能性もゼロではないが、
現在の設定(ハードもソフトも)で何の問題もない「ハズ」なのに・・・と
困りきっております。

どうせこれ以上悪くはならないだろうし、失敗してもOSの入れ直しするだけと
試してみようと思ったのですが、現在インターネットに接続出来るのはMacだけなので、
95クライアントにファイルを移動させる方法がなくて挫折しました。

投稿日時 - 2002-05-12 12:50:47

ANo.5

イッツコムってもともとマック用のプロバイダ じゃないんですか?
Win と MAC はTCP/IP を使ってはいるけどプロトコルが違うらしいですよ。
CATVに問い合わせした時、ちゃんとWindowsパソコン って いいました?

PC MACLAN ってゆうソフトがあってMACのプロトコルに対応可能らしいんですが なんせ 定価2万7千7百円だそうな 普通諦めますよネ
どっかフリーソフトを当たってみた方がいいかも!

投稿日時 - 2002-05-11 21:15:39

補足

度々恐れ入ります。

Mac用のプロバイダってことはないと思いますが、
もちろんサポートにはWindows95での不具合ってことで対応してもらってます。

投稿日時 - 2002-05-11 21:58:58

ANo.4

ところで、DHCPって どこにある?

チョット イッツコムについて検索してみました。
評判悪いですね
スピードが遅いとか、不安定とか、固定アドレスとか

もしかして、イッツコムから割り振られているのは、固定アドレスではありませんか?

どうも、特殊で  普通のプロバイダとは 全く違うみたい。

私の知識不足でした。申し訳ない バンザイ(お手上げ)です。

投稿日時 - 2002-05-11 18:08:07

補足

いろいろとお手数をお掛けします。

iTSCOMからはアドレスは固定で割り振られません。
ですから本来はIPを自動取得に設定するだけで簡単につながってしまうらしいのですが・・・。

DHCPも参照する設定をするだけで、その手がかりとして「catv.ne.jp」の
ドメインを検索するだけのようです。

・・・ちなみに、接続が出来ているMacクライアントから
プロバイダのルーターにPINGを投げるとOKなのですが、
問題の95クライアントから同じIPにPINGを投げてもダメでした。

投稿日時 - 2002-05-11 20:25:09

ANo.3

一部のプロバイダでは、DHCPサーバ側でクライアントのMACアドレスのチェックを行い、IPアドレスのリースの許可を出したり、特定のクライアントに同じIPアドレスを割り当てたりしています。

本文中に出てくる別クライアントに、ENW-8300-T、Ether2 ISA-T以外のLANボードが取りつけられているのであれば、それを外してWin95機に取り付けてみてはどうでしょうか。
上記ような問題であれば、これでいけるようになると思います。

iTSCOMのHPにもMACアドレスについての記述は無いですし、サポートの方からもそういった説明はないようなので、可能性は低いと思うのですが・・・。

投稿日時 - 2002-05-11 13:59:20

補足

アドバイスありがとうございます。

本文中にある別クライアントはMacなので、LANボードを外すことは出来ませんが、
いただいたアドバイスのような可能性もあるかと思い、
当初、問題の95クライアントにはEther2 ISA-Tがついていたのですが、
ENW-8300-Tを別途購入し、つけたり外したりしながらテストしているような状態です。

投稿日時 - 2002-05-11 16:43:03

ANo.2

IPアドレス自動取得にしたら、サブネットマスク設定できない は その通りです。

本文で気になるのは、バインドに何も無いのは おかしいです。
マイクロソフト ネットワーククライアント とか マイクロソフト ファミリ ログオン とか 入っているのが 普通 だと思うのですが

コントロールパネル ネットワーク 追加 クライアント で マイクロソフト ネットワーククライアント を 追加してみてください。

投稿日時 - 2002-05-11 10:52:05

補足

iTSCOMに接続する設定では「バインドはすべて外す」ようです。
サポートでも、わざわざOSの「バインドがありませんが選びますか?」の
アラートに対して「いいえ」を選ぶように指示されました。

Windowsのネットワークの仕組みをあまり理解していない為、
そのまま従っていましたが、アドバイス通り「バインドがある状態」で
テストしてみます。

投稿日時 - 2002-05-11 16:37:14

ANo.1

だめもとで実験してみてください。
ゲートウエイ  :ping で 反応があったIP
DNS     :同上
WINS    :解決しない
IP      :自動取得
サブネットマスク:255.255.255.0

サブネットマスク 合ってますよネ

投稿日時 - 2002-05-10 20:59:53

補足

早速アドバイスをいただき、ありがとうございます。
残念ながらうまくいきませんでした。

いただいたアドバイスでひとつわからないのは。IPを自動取得にするとサブネットマスクも設定出来なくなり、
アドバイスにあるように255.255.255.0には出来ないことです。

投稿日時 - 2002-05-11 00:20:55

あなたにオススメの質問